Download 

Stable version 3.19 (Jun 06th 2014)
Developement version 3.192 (Aug 28th 2014)

W3Perl is a free software distributed under the GNU General Public License.

If you want to send bug report or installation problem, use this form
If you want to leave any comments/suggestions or requests for help, please leave a message in the forum

Stable
Version : 3.19 - Jun 06th 2014  - 10 Mb
Linux
linux
Windows (3) (7)
windows
Mac (7)
macos
Installation guide Installation guide Installation guide
Tarball
tarball
(w3perl.tar.gz)
RPM (1)
rpm
(w3perl-3.17-1mdv.noarch.rpm)
SRPM (2)
srpm
(w3perl-3.19-1.src.rpm)
Debian/Ubuntu (5)
ubuntu
(w3perl_3.19_all.deb)
IIS (4)
iis
(w3perl-iis.exe)
Apache (6)
apache
(w3perl-apache.exe)
Abyss
abyss
(w3perl-abyss.exe)
No server (8)
no_server
(w3perl.exe)
MacOS X
dmg
(w3perl.dmg)
download
download  Mandriva
download  openSUSE
  download   download download   download download download   download

RPM and Debian packages have been improved since 3.17

(1) If you want to use the old way to generate graphs, you need first to install Fly or Flydraw (SRPM available)
(2) Others distributions will need to rebuilt the package from the source SRPM
(3) ActivePerl must be installed first. Strawberryperl can be used with no-server package (as it doesn't map CGI perl extension).
(4) You must have an IIS server running - IIS 7 users should install the IIS 6.0 metabase compatibility and CGI component.
(5) Alien conversion (use default Ubuntu path for Apache)
(6) Installer require Apache version > 2.2.10
(7) Optional Fly package included within the installer
(8) Many features are not available as they require Ajax or CGI (date selection, page graphic, header info...)

Developement
Version : 3.192 - Aug 28th 2014
Linux
linux
Windows
windows
Mac
macos
Tarball
tarball
(w3perl-dev.tar.gz)
IIS
iis
(w3perl-iis-dev.exe)
Apache
apache
(w3perl-apache-dev.exe)
Abyss
abyss
(w3perl-abyss-dev.exe)
No server
no_server
(w3perl-dev.exe)
MacOS X
dmg
(w3perl-dev.dmg)
download
5.1 Mb
download
4.7 Mb
  download
5.1 Mb
  download
5.1 Mb
  download
5.1 Mb
  download
5.2 Mb
Unix : In order to upgrade to the dev package, just untar the dev package over your current w3perl install directory and run the upgrade.pl script.
Windows : the package will upgrade if needed.
Plugins
      Linux
linux
Windows
windows
 
Fly/Flydraw (***) 2.0.1 Optional Tarball
Deb
Included Graphical output
Htmldoc 1.8.28 Optional Tarball
Local (1.8.27)
PDF export
MIME::Lite module 3.030 Optional Tarball
PPM
Email report
Geo::IP module 1.43 Optional Tarball (*) RPM SRPM GeoIP (*) Geographical mapping from IP
Geo:IPfree module 1.140470 Optional Geo-IPfree (**) Geo-IPfree (**) Geographical mapping from IP
DBI module 1.631 Optional DBI DBI SPIP Database access
Socket6 module 0.23 Optional Socket6 Socket6 Ipv6 support for Perl < 5.14

(*) You need first to install the Maxmind GeoIP C Library
(**) Geo-IPfree is a free perl module not related to a company
- Latest update for GeoIP database can be found on the Maxmind website
- Use Geo::IP OR Geo:IPfree module as they do the same job.
- Help about installing is available
(***) Fly/Flydraw is optional from 3.17